火山安卓提示此应用专为旧版android打造,因此可能无法运行


时间: 2021-12-12 09:24:53 人气: 96 评论: 0

将“目标安卓平台SDK的API级别”,修改为“26(8.0版)”或更高版本,可解决APP提示“此应用专为旧版Android打造,可能无法...”的问题,但最好将目标API设置为最新API。

升级 API 不仅有助于提升 Android 安全与隐私的防护水平,而且还能有效预防应用对设备zy (如电量和内存) 的异常消耗,从而为用户提供更好的产品体验。

我们发现在 Play Store 之外,超过 95% 的间谍应用故意将目标 API 等级设置为 22 或更低,以便其运行在较新版本 Android 系统上时也能绕过运行时的权限请求。

在Android5.1.1版本(API22)及以前,使用权限不需要动态申请(为所欲为?),在Android6.0版本(API23)及后续版本,使用一些重要(危险)权限,需要动态申请,用户同意后才能使用该权限,这是谷歌出于安全等方面的考虑。

火山 安卓 提示 应用 android

评论